libfm: add optional support for gtk3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 23 Jul 2016 13:31:24 +0000 (10:31 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 15:00:41 +0000 (17:00 +0200)
pcmanfm can now use gtk3+ so use that over gtk2+ if it's available.
Since it's only x11-safe for the moment the comment and deps other than
gtk stay the same.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfm/Config.in
package/libfm/libfm.mk

index 603b4d51ee678583da96b449f2c1fa560245e9f1..0463d1c5d7b6f9427f64ae273908c04b6c3f5025 100644 (file)
@@ -2,7 +2,7 @@ config BR2_PACKAGE_LIBFM
        bool "libfm"
        select BR2_PACKAGE_MENU_CACHE
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_LIBGTK2
+       select BR2_PACKAGE_LIBGTK2 if !BR2_PACKAGE_LIBGTK3_X11
        select BR2_PACKAGE_CAIRO
        depends on BR2_PACKAGE_XORG7
        depends on BR2_USE_WCHAR # libglib2
index a9be09450bded70ea3d373fb992e52d7dc0cd471..633a844d8dc6fda12d3323cbdf142d00b2ed278e 100644 (file)
@@ -7,7 +7,7 @@
 LIBFM_VERSION = 1.2.4
 LIBFM_SOURCE = libfm-$(LIBFM_VERSION).tar.xz
 LIBFM_SITE = http://sourceforge.net/projects/pcmanfm/files
-LIBFM_DEPENDENCIES = menu-cache libgtk2 libglib2 cairo
+LIBFM_DEPENDENCIES = menu-cache libglib2 cairo
 LIBFM_LICENSE = GPLv2+, LGPLv2.1+
 LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
 LIBFM_INSTALL_STAGING = YES
@@ -19,4 +19,12 @@ else
 LIBFM_CONF_OPTS += --disable-exif
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
+LIBFM_CONF_OPTS += --with-gtk=3
+LIBFM_DEPENDENCIES += libgtk3
+else
+LIBFM_CONF_OPTS += --with-gtk=2
+LIBFM_DEPENDENCIES += libgtk2
+endif
+
 $(eval $(autotools-package))