package/mc: fix typo BR2_PACKAGE_GMP -> BR2_PACKAGE_GPM
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Apr 2020 07:49:57 +0000 (09:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Apr 2020 07:51:11 +0000 (09:51 +0200)
Commit 9cae8f557b9d3f18ccf3694155f452d6b55de5f6 introduced an optional
dependency on GPM, but got the name of the option wrong, and used
GMP. In fact, even the commit title was wrong.

This causes a build failure:

Makefile:578: *** gpm is in the dependency chain of mc that has added it to its _DEPENDENCIES variable without selecting it or depending on it from Config.in.  Stop.

Fixes:

  http://autobuild.buildroot.net/results/52fb92ae7dd55cba7d19862bb6cd89c80da9a4b6/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mc/mc.mk

index 3deffeefee79d44657579bce247e9f795caf0947..f83905d89b06e188c5db9aa0e6ead3725362bcb8 100644 (file)
@@ -11,7 +11,7 @@ MC_LICENSE = GPL-3.0+
 MC_LICENSE_FILES = COPYING
 MC_DEPENDENCIES = libglib2 host-pkgconf
 
-ifeq ($(BR2_PACKAGE_GMP),y)
+ifeq ($(BR2_PACKAGE_GPM),y)
 MC_CONF_OPTS += --with-gpm-mouse
 MC_DEPENDENCIES += gpm
 else