projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6f4b5e0
)
package/pkg-qmake.mk: only add qt5base dependency when we're not qt5base
author
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Mon, 9 Mar 2020 22:16:30 +0000
(23:16 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Mon, 9 Mar 2020 22:17:11 +0000
(23:17 +0100)
As we are about to convert qt5base to the qmake-package
infrastructure, we need to avoid a circular dependency: the qt5base
package itself should not depend on qt5base.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-qmake.mk
patch
|
blob
|
history
diff --git
a/package/pkg-qmake.mk
b/package/pkg-qmake.mk
index ed48819d1b1fc12009613dfc8e8097c7686f888d..46d2b22d047bd83b5152847334beafa87f8f04e2 100644
(file)
--- a/
package/pkg-qmake.mk
+++ b/
package/pkg-qmake.mk
@@
-40,7
+40,9
@@
$(2)_MAKE_OPTS ?=
$(2)_INSTALL_STAGING_OPTS ?= install
$(2)_INSTALL_TARGET_OPTS ?= $$($(2)_INSTALL_STAGING_OPTS)
+ifneq ($(1),qt5base)
$(2)_DEPENDENCIES += qt5base
+endif
#
# Configure step. Only define it if not already defined by the package