Makefile: do not try to strip inexisting file when stripping libpthread
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Aug 2013 11:03:03 +0000 (13:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 Sep 2013 21:06:19 +0000 (23:06 +0200)
libpthread.so has a special stripping condition to preserve parts of
it that are needed for debugging. However, due to the usage of 'xargs'
instead of 'xargs -r', the strip command is executed regardless of
whether a libpthread.so file is found or not. This leads to a big
error message being displayed in static-only builds, because strip is
executed without a file argument. Thanks to the '|| true', the build
continues, but still shows a big error message in the middle, which is
not nice.

By using 'xargs -r', we avoid the strip command from being executed
when 'find' doesn't find any match. We also remove the '|| true' to
catch other real errors.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 3b5d921dd9ef8b740b0145f17e895e5b6d656b6d..09faebaae0d42d5820354b9b7314b9b56a3b1fbc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -494,7 +494,7 @@ endif
 # I set a breakpoint"
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
        find $(TARGET_DIR)/lib -type f -name 'libpthread*.so*' | \
-               xargs $(STRIPCMD) $(STRIP_STRIP_DEBUG) || true
+               xargs -r $(STRIPCMD) $(STRIP_STRIP_DEBUG)
 endif
 
        mkdir -p $(TARGET_DIR)/etc