mpd: fix vorbis build failure
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 7 Feb 2014 13:24:45 +0000 (10:24 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Feb 2014 14:15:44 +0000 (15:15 +0100)
Forcibly disable the vorbis encoder support when the vorbis option isn't
enabled to avoid autodetection.
Said autodetection has a build bug that it won't properly set libvorbis
build options when the decoder is disabled. Fixes:
http://autobuild.buildroot.net/results/a46/a46b4c97fe126b23a96051a8bf1243a7f4935434/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/mpd.mk

index 4a7926cd6143784d12f7070c611f9fa72819402d..6bdb149712519e479f5ec061d24722cf7149d953 100644 (file)
@@ -91,7 +91,7 @@ endif
 ifeq ($(BR2_PACKAGE_MPD_VORBIS),y)
 MPD_DEPENDENCIES += libvorbis
 else
-MPD_CONF_OPT += --disable-vorbis
+MPD_CONF_OPT += --disable-vorbis --disable-vorbis-encoder
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_MPG123),y)