toolchain: adjust version check to allow for single numbers
authorNorbert Lange <nolange79@gmail.com>
Wed, 10 Jun 2020 23:53:12 +0000 (01:53 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Jun 2020 20:11:06 +0000 (22:11 +0200)
A gcc compiler, which was configured with
--with-gcc-major-version-only, will only return a single
number. (debian does this for example).

A simple modification allows the check to work with both
single numbers (eg. '9') and full versions (eg. '9.2.1').

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
toolchain/helpers.mk

index 44d0c83d1e79f00f13f05ff38ed5138fa1f4f3e9..17bc159f3eda52df5cd67b736a28499161ecec74 100644 (file)
@@ -184,7 +184,7 @@ check_gcc_version = \
                exit 0 ; \
        fi; \
        real_version=`$(1) -dumpversion` ; \
-       if [[ ! "$${real_version}" =~ ^$${expected_version}\. ]] ; then \
+       if [[ ! "$${real_version}." =~ ^$${expected_version}\. ]] ; then \
                printf "Incorrect selection of gcc version: expected %s.x, got %s\n" \
                        "$${expected_version}" "$${real_version}" ; \
                exit 1 ; \