package/freerdp: do not use Neon extensions when not available
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 27 Dec 2014 18:16:06 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 18:59:39 +0000 (19:59 +0100)
FreeRDP mis-detects the CPU, and may enable Neon extensions when it
should not. Not all ARM processors have Neon extensions.

Heck, what's more, none non-ARM processor has Neon extensions!
The regexp to detect the CPU is borked:  'arm*'  will also match 'arc'
as well as 'arm'.

Do not let FreeRDP try to decide if it can use Neon extensions, we have
a Kconfig option for that, that we can use to force FreeRDP to use it or
not.

Should fix:
    http://autobuild.buildroot.org/results/d4a/d4a61e686cf11d993d02ece0c4e2835a926603c2/
    http://autobuild.buildroot.org/results/234/2349d40ef8d658ab1cd7332eb1b42a75afcd423f/
   ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freerdp/freerdp.mk

index d2e51f8ec4a43ef8bbc31fa6bdc273cf80b518ad..c9396b5ec6f9b2322a9107dc386f326c78f52580 100644 (file)
@@ -63,4 +63,10 @@ else
 FREERDP_CONF_OPTS += -DWITH_XV=OFF
 endif
 
+ifeq ($(BR2_ARM_CPU_HAS_NEON),y)
+FREERDP_CONF_OPTS += -DWITH_NEON=ON
+else
+FREERDP_CONF_OPTS += -DWITH_NEON=OFF
+endif
+
 $(eval $(cmake-package))