Makefile: be sure the default rule 'all:' is the first one
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 11 Oct 2014 17:34:42 +0000 (19:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 05:46:26 +0000 (07:46 +0200)
In the coming patch, we are going to change the order in which our rules
are defined, because we include the gendoc infra before we define the
'all:' rule, so we need to decalre the 'all:' rule before we include
gendoc.

Declare it very, very early in the Makefile, so it always kick in first.
The actual dependency is still declared much later, all that counts is
that "all:" is first.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 3f5664811f64ae0c774f3614e0c2fed25bcbf16a..525dd9c6f3d9b7054b6766abc38f425b9157a870 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,9 @@
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
 
+# This is our default rule, so must come first
+all:
+
 # Set and export the version string
 export BR2_VERSION := 2014.11-git