uclibc: add explicit setup of ARC-specific options
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Thu, 30 Oct 2014 13:57:28 +0000 (16:57 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 2 Nov 2014 21:22:44 +0000 (22:22 +0100)
As with other architectures for ARC we need to have an ability to set
specific options in uClibc.

In particular this is required for selection of ARC ISA version.

[Peter: string type, so must be in quotes as noted by Yann]
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Anton Kolesov <akolesov@synopsys.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index d319ae78412191e19e4b1d33e5260e096d8b9433..0aaefa33fcfd03b9a2bed14de8cf3ce211b3e545 100644 (file)
@@ -194,6 +194,12 @@ config BR2_UCLIBC_TARGET_ARCH
        default i386       if BR2_i386
        default x86_64     if BR2_x86_64
 
+config BR2_UCLIBC_ARC_TYPE
+       string
+       depends on BR2_UCLIBC_TARGET_ARCH = "arc"
+       default "ARC_CPU_700"   if BR2_arc750d
+       default "ARC_CPU_700"   if BR2_arc770d
+
 config BR2_UCLIBC_ARM_BX
        bool
        depends on BR2_UCLIBC_TARGET_ARCH = "arm"
index b2ecce397b140e7cc10bbbcf5b8d5994a14e7719..8f990c7b870ce53d8f479f5ffe85a977fbc3a259 100644 (file)
@@ -56,6 +56,17 @@ UCLIBC_LOCALES = $(foreach locale,$(GENERATE_LOCALE),\
                   $(firstword $(subst .,$(space),$(locale))))
 endif
 
+#
+# ARC definitions
+#
+
+ifeq ($(UCLIBC_TARGET_ARCH),arc)
+UCLIBC_ARC_TYPE = CONFIG_$(call qstrip,$(BR2_UCLIBC_ARC_TYPE))
+define UCLIBC_ARC_TYPE_CONFIG
+       $(call KCONFIG_ENABLE_OPT,$(UCLIBC_ARC_TYPE),$(@D)/.config)
+endef
+endif # arc
+
 #
 # ARM definitions
 #
@@ -410,6 +421,7 @@ define UCLIBC_KCONFIG_FIXUP_CMDS
        $(call KCONFIG_SET_OPT,DEVEL_PREFIX,"/usr",$(@D)/.config)
        $(call KCONFIG_SET_OPT,SHARED_LIB_LOADER_PREFIX,"/lib",$(@D)/.config)
        $(UCLIBC_MMU_CONFIG)
+       $(UCLIBC_ARC_TYPE_CONFIG)
        $(UCLIBC_ARM_ABI_CONFIG)
        $(UCLIBC_ARM_BX_CONFIG)
        $(UCLIBC_MIPS_ABI_CONFIG)