gst-plugins-good: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 29 Sep 2011 14:55:08 +0000 (16:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 29 Sep 2011 14:55:08 +0000 (16:55 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index e560ea85969ee19d523b79ddb1d44dbbcb65ed67..1fc66a35724d16faa2a4346906143be3ba3d4f7c 100644 (file)
@@ -45,6 +45,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_APETAG
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOFX
        bool "audiofx"
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOPARSERS
+       bool "audioparsers"
+
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUPARSE
        bool "auparse"
 
@@ -94,6 +97,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_IMAGEFREEZE
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_INTERLEAVE
        bool "interleave"
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ISOMP4
+       bool "isomp4"
+
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LAW
        bool "law"
 
@@ -112,9 +118,6 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIFILE
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIPART
        bool "multipart"
 
-config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_QTDEMUX
-       bool "qtdemux"
-
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_REPLAYGAIN
        bool "replaygain"
 
index eeff26600ec0bf98eaf270b9c8690331ef1e8f7f..202e60e70f53f74c004dcf03797421242901b37f 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-good
 #
 #############################################################
-GST_PLUGINS_GOOD_VERSION = 0.10.28
+GST_PLUGINS_GOOD_VERSION = 0.10.30
 GST_PLUGINS_GOOD_SOURCE = gst-plugins-good-$(GST_PLUGINS_GOOD_VERSION).tar.bz2
 GST_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
 
@@ -72,6 +72,12 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-audiofx
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOPARSERS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-audioparsers
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-audioparsers
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUPARSE),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-auparse
 else
@@ -168,6 +174,12 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-interleave
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ISOMP4),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-isomp4
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-isomp4
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LAW),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-law
 else
@@ -204,12 +216,6 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-multipart
 endif
 
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_QTDEMUX),y)
-GST_PLUGINS_GOOD_CONF_OPT += --enable-qtdemux
-else
-GST_PLUGINS_GOOD_CONF_OPT += --disable-qtdemux
-endif
-
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_REPLAYGAIN),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-replaygain
 else