busybox: pass EXTRA_LDFLAGS for external toolchains
authorGrant Edwards <grant.b.edwards@gmail.com>
Sat, 1 May 2010 18:57:28 +0000 (20:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 1 May 2010 18:57:28 +0000 (20:57 +0200)
Closes #1321

[Peter: Rework patch to make it apply to git]
Signed-off-by: Grant Edwards <grant.b.edwards@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/busybox/busybox.mk

diff --git a/CHANGES b/CHANGES
index 4eccaf024403deab513444cee64f3f55c344faec..46b975749c9da04a71a8c24a0da8c7c5e49225f6 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -47,6 +47,7 @@
        #1219: kernel headers not correctly installed into toolchain/staging
        #1273: BR2_INET_IPV6 does not enable IPv6 in pppd
        #1303: Add librsync package
+       #1321: Busybox link fails due to lack of --sysroot option
        #1327: mtd-utils compile failure due to lack of --sysroot in CFLAGS
        #1345: Bump pppd to 2.4.5 and convert to Makefile.autotools.in
        #1369: cannot build radvd (flex problem)
index 05a6d941c123c232b3c020a0b6567e48b267b4d7..668861d5b3d7e860f7b97a4c0344bff89d799fa1 100644 (file)
@@ -107,12 +107,14 @@ endif
 $(BUSYBOX_DIR)/busybox: $(BUSYBOX_DIR)/.config
        $(MAKE) CC=$(TARGET_CC) CROSS_COMPILE="$(TARGET_CROSS)" \
                CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" \
+               EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
                ARCH=$(KERNEL_ARCH) -C $(BUSYBOX_DIR)
 
 $(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
 ifeq ($(BR2_PACKAGE_BUSYBOX_FULLINSTALL),y)
        $(MAKE) CC=$(TARGET_CC) CROSS_COMPILE="$(TARGET_CROSS)" \
                CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" \
+               EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
                ARCH=$(KERNEL_ARCH) -C $(BUSYBOX_DIR) install
 else
        install -D -m 0755 $(BUSYBOX_DIR)/busybox $(TARGET_DIR)/bin/busybox