luarocks: move the option --deps-mode
authorFrancois Perrad <fperrad@gmail.com>
Fri, 25 Jul 2014 18:21:25 +0000 (20:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Jul 2014 07:04:05 +0000 (09:04 +0200)
The option moves from `luarocks make` command to the LuaRocks config file.

This change and the merge of PR https://github.com/keplerproject/luarocks/pull/236
in LuaRocks 2.2.0 avoids the confusing message "Missing dependency"

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/luarocks/luarocks.mk
package/pkg-luarocks.mk

index 19c1c948405c735bfd32eb6c94e65ed5c3ea5472..5f7f3952e7b4ed57bcd31b12a7aa7d548bfed2d4 100644 (file)
@@ -38,6 +38,7 @@ define HOST_LUAROCKS_INSTALL_CMDS
        echo "gcc_rpath = false"                                >> $(LUAROCKS_CONFIG_FILE)
        echo "rocks_trees = { [[$(TARGET_DIR)/usr]] }"          >> $(LUAROCKS_CONFIG_FILE)
        echo "wrap_bin_scripts = false"                         >> $(LUAROCKS_CONFIG_FILE)
+       echo "deps_mode = [[none]]"                             >> $(LUAROCKS_CONFIG_FILE)
 endef
 
 $(eval $(host-generic-package))
index be0d4cc072fd6d60bf0b76df095dfda9170df116..95b397c9f9a8c59a47e1ab010ee9797426bde7ba 100644 (file)
@@ -59,7 +59,7 @@ endif
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
        cd $$($(2)_SRCDIR) && \
-        $$(LUAROCKS_RUN) make --deps-mode=none --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPT)
+        $$(LUAROCKS_RUN) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPT)
 endef
 endif