host-python-pyrex: use the HOST_*_NEEDS_HOST_PYTHON infrastructure
authorSamuel Martin <s.martin49@gmail.com>
Mon, 14 Apr 2014 22:09:49 +0000 (00:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Apr 2014 21:18:20 +0000 (23:18 +0200)
python-pyrex does not support python3.

So, using the *_NEEDS_HOST_PYTHON infrastructure will make sure we won't try
building it for python3. Besides, it will automatically take care of adding the
right host-python package to the dependency list.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-pyrex/python-pyrex.mk

index 73cb16382bc25d1b927f298af7ad9c0aa93c6d02..7f424ad3507755f597d4b2032421c92249b230e2 100644 (file)
@@ -7,9 +7,9 @@
 PYTHON_PYREX_VERSION = 0.9.9
 PYTHON_PYREX_SOURCE = Pyrex-$(PYTHON_PYREX_VERSION).tar.gz
 PYTHON_PYREX_SITE = http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/
-PYTHON_PYREX_DEPENDENCIES = host-python
 PYTHON_PYREX_LICENSE = Apache-v2
 PYTHON_PYREX_LICENSE_FILES = LICENSE.txt
 PYTHON_PYREX_SETUP_TYPE = distutils
+HOST_PYTHON_PYREX_NEEDS_HOST_PYTHON = python2
 
 $(eval $(host-python-package))