alsa-lib: make sure to only look in STAGING_DIR for Python includes
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Jul 2010 21:26:25 +0000 (23:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Jul 2010 21:26:25 +0000 (23:26 +0200)
Even though we pass a -I option to tell alsa-lib to look for Python
includes in the STAGING_DIR, alsa-lib build process still looks in
/usr/include for some stuff, causing bug #321.

This fix is the one suggested by Ulf Samuelsson in bug #321, and
allows to make alsa-lib with Python support to build properly on a 64
bits machine with python-dev installed on the host. Without this fix,
the build fails with exactly the same problem that Ulf reported.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/multimedia/alsa-lib/alsa-lib.mk

index 1f120c6f7483042939f4b94ad21125a643bf661c..6e4c5754f9186f9d10fbd8aeaf97123a6298bee3 100644 (file)
@@ -54,7 +54,9 @@ ALSA_LIB_CFLAGS+=-DAVR32_INLINE_BUG
 endif
 
 ifeq ($(BR2_PACKAGE_ALSA_LIB_PYTHON),y)
-ALSA_LIB_CONF_OPT += --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR)
+ALSA_LIB_CONF_OPT += \
+       --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR) \
+       --with-pythonincludes=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
 ALSA_LIB_CFLAGS+=-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
 ALSA_LIB_DEPENDENCIES = libpython
 else