package/shairport-sync: bump to version 2.4
authorJörg Krause <joerg.krause@embedded.rocks>
Tue, 8 Sep 2015 06:49:43 +0000 (08:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Sep 2015 13:05:40 +0000 (15:05 +0200)
Version 2.4 of shairport-sync introduces new optional features (metadata,
stdout, pipe) which we enable by default. The impact on the binary size is
about 18 kB (110 kB vs 92 kB) for an ARM target.

Also add a new dependency to libconfig and install the default config script.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/shairport-sync/Config.in
package/shairport-sync/shairport-sync.mk

index c1d81a7e2a54189dc029802363a67dabe97dd8d8..c558a64c5be66a8bc9cf38f311cac28c60ae2c83 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_SHAIRPORT_SYNC
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        select BR2_PACKAGE_ALSA_LIB
        select BR2_PACKAGE_ALSA_LIB_MIXER
+       select BR2_PACKAGE_LIBCONFIG
        select BR2_PACKAGE_LIBDAEMON
        select BR2_PACKAGE_POLARSSL if !BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_POPT
index 881cceda2c34d579f639748f69c638ec4880c6ad..dc36c0ea0dbc194a81e6f598f4dc3169d489c48f 100644 (file)
@@ -4,17 +4,20 @@
 #
 ################################################################################
 
-SHAIRPORT_SYNC_VERSION = 2.2.4
+SHAIRPORT_SYNC_VERSION = 2.4
 SHAIRPORT_SYNC_SITE = $(call github,mikebrady,shairport-sync,$(SHAIRPORT_SYNC_VERSION))
 
 SHAIRPORT_SYNC_LICENSE = MIT, BSD-3c
 SHAIRPORT_SYNC_LICENSE_FILES = LICENSES
-SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libdaemon popt host-pkgconf
+SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libconfig libdaemon popt host-pkgconf
 
 # Touching configure.ac with the patches
 SHAIRPORT_SYNC_AUTORECONF = YES
 
-SHAIRPORT_SYNC_CONF_OPTS = --with-alsa
+SHAIRPORT_SYNC_CONF_OPTS = --with-alsa \
+       --with-metadata \
+       --with-pipe \
+       --with-stdout
 
 # Avahi or tinysvcmdns (shaiport-sync bundles its own version of tinysvcmdns).
 # Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
@@ -45,6 +48,8 @@ endif
 define SHAIRPORT_SYNC_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/shairport-sync \
                $(TARGET_DIR)/usr/bin/shairport-sync
+       $(INSTALL) -D -m 0644 $(@D)/scripts/shairport-sync.conf \
+               $(TARGET_DIR)/etc/shairport-sync.conf
 endef
 
 define SHAIRPORT_SYNC_INSTALL_INIT_SYSV