ruby: should not use dl_iterate_phdr() on Blackfin
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 28 Aug 2014 22:17:38 +0000 (00:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Aug 2014 07:16:00 +0000 (09:16 +0200)
The dl_iterate_phdr() C library function on Blackfin returns a
non-conventional structure format compared to other architectures,
which makes Ruby unable to use it. Since it's just an optional feature
of Ruby apparently used to generate more fancy backtraces, this commit
simply disables the usage of dl_iterate_phdr() on this architecture.

Fixes:

  http://autobuild.buildroot.org/results/1b0/1b0e2f5f95889eb26846927da45d128247d0ed89/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ruby/ruby.mk

index 66556c376791354568dc8128bafdde4f151d119f..b84aaf3dc992849a707b56f48e5601786005e328 100644 (file)
@@ -28,6 +28,10 @@ RUBY_CFLAGS += -O2
 endif
 RUBY_CONF_ENV = CFLAGS="$(RUBY_CFLAGS)"
 
+ifeq ($(BR2_bfin),y)
+RUBY_CONF_ENV = ac_cv_func_dl_iterate_phdr=no
+endif
+
 # Force optionals to build before we do
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
        RUBY_DEPENDENCIES += berkeleydb