package/qt5/qt5mqtt: new package
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Tue, 24 Nov 2020 06:59:16 +0000 (07:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Dec 2020 10:13:39 +0000 (11:13 +0100)
The Qt MQTT module provides a standard compliant implementation of the
MQTT protocol specification.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/qt5/Config.in
package/qt5/qt5mqtt/Config.in [new file with mode: 0644]
package/qt5/qt5mqtt/qt5mqtt.hash [new file with mode: 0644]
package/qt5/qt5mqtt/qt5mqtt.mk [new file with mode: 0644]

index d70f4c2b0427f86aca45b637088542d9d0f5c82d..dc0a104862ee57b0a782c67d25db344bf7ff09ce 100644 (file)
@@ -170,6 +170,7 @@ F:  package/python-pydal/
 F:     package/python-spidev/
 F:     package/python-web2py/
 F:     package/qt5/qt5coap/
+F:     package/qt5/qt5mqtt/
 F:     package/sam-ba/
 F:     package/sshguard/
 F:     package/sunwait/
index 9431f4980d4349091fcea6b0dc1f63bf9541fa30..c15d27ba7cb655eb459840e19f6e6f4012628a87 100644 (file)
@@ -48,6 +48,7 @@ source "package/qt5/qt5graphicaleffects/Config.in"
 source "package/qt5/qt5imageformats/Config.in"
 source "package/qt5/qt5location/Config.in"
 source "package/qt5/qt5lottie/Config.in"
+source "package/qt5/qt5mqtt/Config.in"
 source "package/qt5/qt5multimedia/Config.in"
 source "package/qt5/qt5quickcontrols/Config.in"
 source "package/qt5/qt5quickcontrols2/Config.in"
diff --git a/package/qt5/qt5mqtt/Config.in b/package/qt5/qt5mqtt/Config.in
new file mode 100644 (file)
index 0000000..d81575e
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_QT5MQTT
+       bool "qt5mqtt"
+       help
+         Qt is a cross-platform application and UI framework for
+         developers using C++.
+
+         The Qt MQTT module provides a standard compliant
+         implementation of the MQTT protocol specification. It
+         enables applications to act as telemetry displays and
+         devices to publish telemetry data.  The supported versions
+         are MQTT 3.1, MQTT 3.1.1, and MQTT 5.0.
+
+         https://doc.qt.io/QtMQTT/index.html
diff --git a/package/qt5/qt5mqtt/qt5mqtt.hash b/package/qt5/qt5mqtt/qt5mqtt.hash
new file mode 100644 (file)
index 0000000..ddf2aa4
--- /dev/null
@@ -0,0 +1,6 @@
+# Hash locally calculated
+sha256  603f81095ec837cb28b93189fd26dbbae32ecaedd80f6dd88c85050b51e18008  qt5mqtt-5.15.1.tar.gz
+
+# Hashes for license files:
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE.GPL3
+sha256  0dbe024961f6ab5c52689cbd036c977975d0d0f6a67ff97762d96cb819dd5652  LICENSE.GPL3-EXCEPT
diff --git a/package/qt5/qt5mqtt/qt5mqtt.mk b/package/qt5/qt5mqtt/qt5mqtt.mk
new file mode 100644 (file)
index 0000000..40ad616
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# qt5mqtt
+#
+################################################################################
+
+QT5MQTT_VERSION = $(QT5_VERSION)
+QT5MQTT_SITE = $(call github,qt,qtmqtt,v$(QT5_VERSION))
+QT5MQTT_INSTALL_STAGING = YES
+QT5MQTT_LICENSE = GPL-3.0 with exception
+QT5MQTT_LICENSE_FILES = LICENSE.GPL3 LICENSE.GPL3-EXCEPT
+QT5MQTT_SYNC_QT_HEADERS = YES
+
+$(eval $(qmake-package))