mp4v2: new package
authorJörg Krause <jkrause@posteo.de>
Mon, 20 Oct 2014 08:16:59 +0000 (10:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 13:09:25 +0000 (14:09 +0100)
[Thomas: use --enable-largefile/--disable-largefile as appropriate.]

Signed-off-by: Jörg Krause <jkrause@posteo.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/mp4v2/Config.in [new file with mode: 0644]
package/mp4v2/mp4v2.hash [new file with mode: 0644]
package/mp4v2/mp4v2.mk [new file with mode: 0644]

index 9e361b94695a1ee411bc4af90d88eec4be6f24fe..33d270c3a31b71e53d44dfd5f5e23f78a7049b78 100644 (file)
@@ -558,6 +558,7 @@ menu "Audio/Sound"
        source "package/libsndfile/Config.in"
        source "package/libsoxr/Config.in"
        source "package/libvorbis/Config.in"
+       source "package/mp4v2/Config.in"
        source "package/opencore-amr/Config.in"
        source "package/opus/Config.in"
        source "package/portaudio/Config.in"
diff --git a/package/mp4v2/Config.in b/package/mp4v2/Config.in
new file mode 100644 (file)
index 0000000..42315a2
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_MP4V2
+       bool "mp4v2"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         The MP4v2 library provides functions to read, create, and
+         modify mp4 files.
+
+         https://code.google.com/p/mp4v2/
+
+if BR2_PACKAGE_MP4V2
+
+config BR2_PACKAGE_MP4V2_UTIL
+       bool "Install mp4 command line tools"
+       help
+         Enable to install the mp4 command line tools mp4art,
+         mp4chaps, mp4extract, mp4info, mp4subtitle, mp4tags, and
+         mp4trackdump.
+
+endif
+
+comment "mp4v2 needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/mp4v2/mp4v2.hash b/package/mp4v2/mp4v2.hash
new file mode 100644 (file)
index 0000000..d5a49c4
--- /dev/null
@@ -0,0 +1,2 @@
+# From https://code.google.com/p/mp4v2/downloads/detail?name=mp4v2-2.0.0.tar.bz2
+sha1 193260cfb7201e6ec250137bcca1468d4d20e2f0 mp4v2-2.0.0.tar.bz2
diff --git a/package/mp4v2/mp4v2.mk b/package/mp4v2/mp4v2.mk
new file mode 100644 (file)
index 0000000..c89b7e0
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# mp4v2
+#
+################################################################################
+
+MP4V2_VERSION = 2.0.0
+MP4V2_SOURCE = mp4v2-$(MP4V2_VERSION).tar.bz2
+MP4V2_SITE = https://mp4v2.googlecode.com/files
+MP4V2_INSTALL_STAGING = YES
+MP4V2_LICENSE = MPLv1.1
+MP4V2_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_LARGEFILE),y)
+MP4V2_CONF_OPTS += --enable-largefile
+else
+MP4V2_CONF_OPTS += --disable-largefile
+endif
+
+ifeq ($(BR2_PACKAGE_MP4V2_UTIL),y)
+MP4V2_CONF_OPTS += --enable-util
+else
+MP4V2_CONF_OPTS += --disable-util
+endif
+
+$(eval $(autotools-package))