package/alsa-utils: fix systemd build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Dec 2018 15:54:35 +0000 (16:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 14 Dec 2018 21:38:19 +0000 (22:38 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

alsa-utils uses the systemdsystemunitdir variable from systemd.pc to
decide where to install things. Since DESTDIR is prepended to the
install destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the
systemdsystemunitdir to use explicitly instead of relying on systemd.pc.

Fixes:
 - http://autobuild.buildroot.org/results/d8ad140ae52b4fe8e153de3835f3f17e92b58e53

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/alsa-utils/alsa-utils.mk

index 0bf2b432bd1d474e3d385037d7a93f54ad9cd519..4ce4aace46e6bc30e4678ccf9d11665405880746 100644 (file)
@@ -84,6 +84,7 @@ endef
 
 ifeq ($(BR2_PACKAGE_ALSA_UTILS_ALSACTL)$(BR2_INIT_SYSTEMD),yy)
 ALSA_UTILS_DEPENDENCIES += systemd
+ALSA_UTILS_CONF_OPTS += --with-systemdsystemunitdir=/usr/lib/systemd/system
 define ALSA_UTILS_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 0644 $(@D)/alsactl/alsa-restore.service \
                $(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service