package/pkg-download.mk: add <pkg>_DL_ENV variable
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 19 Dec 2020 15:35:16 +0000 (16:35 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2020 16:14:39 +0000 (17:14 +0100)
This variable can be used by package to pass extra environment
variables to the download logic. It will be used for the Go/Cargo
vendoring.

The <pkg>_DL_ENV variable is intentionally not documented: at this
point, it is not meant to be used by packages directly, but only by
package infrastructures.

Suggested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[yann.morin.1998@free.fr: move the two _ENV variables to the same line]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-download.mk

index 951d2fb5549b2adf111458c402f0211ce271bda1..118df83855a15842267697352e21b2f9edd02eb2 100644 (file)
@@ -99,7 +99,8 @@ endif
 
 define DOWNLOAD
        $(Q)mkdir -p $($(2)_DL_DIR)
-       $(Q)$(EXTRA_ENV) flock $($(2)_DL_DIR)/.lock $(DL_WRAPPER) \
+       $(Q)$(EXTRA_ENV) $($(2)_DL_ENV) \
+               flock $($(2)_DL_DIR)/.lock $(DL_WRAPPER) \
                -c '$($(2)_DL_VERSION)' \
                -d '$($(2)_DL_DIR)' \
                -D '$(DL_DIR)' \