qt5base: add support to build against ICU
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Mar 2013 09:29:39 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:39:39 +0000 (22:39 +0100)
Qt5Webkit requires Qt5Base to be built with ICU support, so we add
such support.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index d313db9185c7a2a35a68f53b7b774215bee21263..79743571184ea4b7901b1921a89be4f8859a6059 100644 (file)
@@ -140,4 +140,11 @@ config BR2_PACKAGE_QT5BASE_DBUS
        help
          This option enables the D-Bus module.
 
+config BR2_PACKAGE_QT5BASE_ICU
+       bool "Enable ICU support"
+       select BR2_PACKAGE_ICU
+       help
+         This option enables ICU support in Qt5. This is for example
+         needed for Qt5Webkit.
+
 endif
index d5dcb7d3f0ead99a00debbdfb870a109818a0d8e..ac63e9814ab67f375f09d81f78edd04243feb859 100644 (file)
@@ -25,7 +25,6 @@ QT5BASE_CONFIGURE_OPTS += \
        -no-nis \
        -no-libudev \
        -no-iconv \
-       -no-icu \
        -no-gstreamer \
        -no-gtkstyle \
        -system-zlib \
@@ -97,6 +96,9 @@ QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_DBUS),dbus)
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_LIBGLIB2),-glib,-no-glib)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_LIBGLIB2),libglib2)
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_ICU),-icu,-no-icu)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_ICU),icu)
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network