package/alsa-utils: optionally depends on gettext
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Oct 2014 14:45:05 +0000 (16:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 17:13:33 +0000 (18:13 +0100)
To get a reproducable build add optional gettext dependency.

- Configure log without gettext

checking for GNU gettext in libc... no
checking for iconv... yes
checking for working iconv... guessing yes
checking for GNU gettext in libintl... no
checking whether to use NLS... no

- Configure log with gettext built before alsa-utils

checking for GNU gettext in libc... no
checking for iconv... yes
checking for working iconv... guessing yes
checking for GNU gettext in libintl... yes
checking whether to use NLS... yes
checking where the gettext function comes from... external libintl
checking how to link with libintl... -lintl

Tested using this defconfig

BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y
BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y
BR2_TOOLCHAIN_BUILDROOT_INET_RPC=y
BR2_TOOLCHAIN_BUILDROOT_LOCALE=y
BR2_PACKAGE_ALSA_UTILS=y
BR2_PACKAGE_ALSA_UTILS_ALSACONF=y
BR2_PACKAGE_ALSA_UTILS_AMIDI=y
BR2_PACKAGE_ALSA_UTILS_AMIXER=y
BR2_PACKAGE_ALSA_UTILS_APLAY=y
BR2_PACKAGE_ALSA_UTILS_IECSET=y
BR2_PACKAGE_ALSA_UTILS_ACONNECT=y
BR2_PACKAGE_ALSA_UTILS_APLAYMIDI=y
BR2_PACKAGE_ALSA_UTILS_ARECORDMIDI=y
BR2_PACKAGE_ALSA_UTILS_ASEQDUMP=y
BR2_PACKAGE_ALSA_UTILS_ASEQNET=y
BR2_PACKAGE_ALSA_UTILS_SPEAKER_TEST=y
BR2_PACKAGE_NCURSES_WCHAR=y

[Thomas:
 - it's not only alsamixer, but also several other alsa-utils
   utilities, like aplay or arecord, which optionally depend on
   gettext. Therefore, the patch was changed to have the optional
   gettext dependency apply to the entire package.
 - in addition, we don't need gettext when locales are enabled:
   alsa-utils builds perfectly fine with a toolchain having locales
   enabled even without gettext. So all we really want is to have
   gettext built before alsa-utils, if gettext is enabled.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/alsa-utils/alsa-utils.mk

index 5eba337ff376f774095b5264bae13550e5026171..208c5fc9db7482dfe281d904f47713ee7adc857b 100644 (file)
@@ -13,6 +13,11 @@ ALSA_UTILS_INSTALL_STAGING = YES
 ALSA_UTILS_DEPENDENCIES = host-gettext host-pkgconf alsa-lib \
        $(if $(BR2_PACKAGE_NCURSES),ncurses)
 
+# gettext support is optional
+ifeq ($(BR2_PACKAGE_GETTEXT),y)
+ALSA_UTILS_DEPENDENCIES += gettext
+endif
+
 ALSA_UTILS_CONF_ENV = \
        ac_cv_prog_ncurses5_config=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)