python-coherence: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 29 Jan 2015 23:19:26 +0000 (00:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Jan 2015 22:14:34 +0000 (23:14 +0100)
[Peter: add missing select for zope-interface]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-coherence/Config.in [new file with mode: 0644]
package/python-coherence/python-coherence.hash [new file with mode: 0644]
package/python-coherence/python-coherence.mk [new file with mode: 0644]

index 3117474e9c5b6b339bc800428f715a1e12ea93e0..d140721ef410905c1ade757d358a89611d36aab2 100644 (file)
@@ -490,6 +490,7 @@ menu "external python modules"
        source "package/python-certifi/Config.in"
        source "package/python-cffi/Config.in"
        source "package/python-cheetah/Config.in"
+       source "package/python-coherence/Config.in"
        source "package/python-configobj/Config.in"
        source "package/python-configshell-fb/Config.in"
        source "package/python-crc16/Config.in"
diff --git a/package/python-coherence/Config.in b/package/python-coherence/Config.in
new file mode 100644 (file)
index 0000000..d4034e7
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_COHERENCE
+       bool "python-coherence"
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON_TWISTED
+       select BR2_PACKAGE_PYTHON_ZOPE_INTERFACE
+       select BR2_PACKAGE_PYTHON_PYASN
+       help
+         A DLNA/UPnP Media Server and Framework for the Digital Living.
+
+         http://coherence-project.org/
diff --git a/package/python-coherence/python-coherence.hash b/package/python-coherence/python-coherence.hash
new file mode 100644 (file)
index 0000000..f788ca3
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  fd5a2db9661994a57232ace4a90d259b6554c43b8bf5bfbf8ec2518c03627922  python-coherence-0.6.6.2.tar.gz
diff --git a/package/python-coherence/python-coherence.mk b/package/python-coherence/python-coherence.mk
new file mode 100644 (file)
index 0000000..301885b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-coherence
+#
+################################################################################
+
+PYTHON_COHERENCE_VERSION = 0.6.6.2
+PYTHON_COHERENCE_SITE = $(call github,coherence-project,Coherence,Coherence-$(PYTHON_COHERENCE_VERSION))
+PYTHON_COHERENCE_SETUP_TYPE = setuptools
+PYTHON_COHERENCE_LICENSE = MIT
+PYTHON_COHERENCE_LICENSE_FILES = LICENSE
+PYTHON_COHERENCE_DEPENDENCIES = python-twisted python-zope-interface python-pyasn
+
+$(eval $(python-package))