perl: bump to version 5.18.2
authorFrancois Perrad <fperrad@gmail.com>
Wed, 8 Jan 2014 12:27:26 +0000 (13:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Jan 2014 21:34:19 +0000 (22:34 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/perl/perl.mk

index 1c7df9b7732bd35117a33d697a3b072347025503..bf8eac212cc6cc56bf3a4716467b722ce7aa58fc 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PERL_VERSION_MAJOR = 18
-PERL_VERSION = 5.$(PERL_VERSION_MAJOR).1
+PERL_VERSION = 5.$(PERL_VERSION_MAJOR).2
 PERL_SITE = http://www.cpan.org/src/5.0
 PERL_SOURCE = perl-$(PERL_VERSION).tar.bz2
 PERL_LICENSE = Artistic or GPLv1+
@@ -85,7 +85,7 @@ endef
 # perlcross's miniperl_top forgets base, which is required by mktables.
 # Instead of patching, it's easier to just set PERL5LIB
 define PERL_BUILD_CMDS
-       PERL5LIB=$(@D)/dist/base/lib $(MAKE1) -C $(@D) perl modules
+       PERL5LIB=$(@D)/dist/base/lib $(MAKE1) -C $(@D) all
 endef
 
 define PERL_INSTALL_STAGING_CMDS