webkitgtk24: use the correct Config.in option for NEON
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Oct 2015 09:20:06 +0000 (11:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Oct 2015 13:23:23 +0000 (15:23 +0200)
In order to enable JIT support on ARM, webkitgtk24 currently looks at
BR2_ARM_ENABLE_NEON, which is not correct: BR2_ARM_CPU_HAS_NEON should
be used instead.

The BR2_ARM_ENABLE_NEON is only visible for cores that select
BR2_ARM_CPU_MAYBE_HAS_NEON, in order to allow to specify if his
particular SoC has chosen to integrate NEON or not. And if so,
BR2_ARM_CPU_HAS_NEON gets selected.

BR2_ARM_CPU_HAS_NEON is in fact selected in two different ways:

 - Either directly by the CPU core selection, if NEON is mandatory in
   this CPU core.

 - Or by BR2_ARM_ENABLE_NEON, for CPU cores where NEON support is
   optional.

So really, BR2_ARM_CPU_HAS_NEON is what should be used by packages.

Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webkitgtk24/webkitgtk24.mk

index a58fed37beae873afcc3341409a49810df4dd427..3be1cc7d83d730bde4b72a7f554172b6433e8f3d 100644 (file)
@@ -88,7 +88,7 @@ endif
 
 # ARM needs NEON for JIT
 # i386 & x86_64 don't seem to have any special requirements
-ifeq ($(BR2_ARM_ENABLE_NEON)$(BR2_i386)$(BR2_x86_64),y)
+ifeq ($(BR2_ARM_CPU_HAS_NEON)$(BR2_i386)$(BR2_x86_64),y)
 WEBKITGTK24_CONF_OPTS += --enable-jit
 else
 WEBKITGTK24_CONF_OPTS += --disable-jit