package/freerdp: drop gstreamer 0.10.x support
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Feb 2020 14:50:23 +0000 (15:50 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 8 Feb 2020 21:42:56 +0000 (22:42 +0100)
With the upcoming removal of gstreamer 0.10, the logic for building freerdp
with support for it must go as well.

As there is now a single option for gstreamer (1.x) support, convert the
gstreamer support choice to a normal option for simplicity.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/freerdp/Config.in
package/freerdp/freerdp.mk

index 34f99b54de04bb15aafecd3e49c045d65177bbc5..96848f7f0647740094cd36e1d48f859b1b4cb55c 100644 (file)
@@ -146,6 +146,13 @@ endif
 
 comment "Legacy options removed in 2020.02"
 
+config BR2_PACKAGE_FREERDP_GSTREAMER
+       bool "freerdp gstreamer 0.10.x support removed"
+       select BR2_LEGACY
+       help
+         Gstreamer 0.10.x is no longer available in Buildroot, so
+         neither is the support in freerdp.
+
 config BR2_PACKAGE_OPENCV3_WITH_GSTREAMER
        bool "opencv3 gstreamer 0.10.x support removed"
        select BR2_LEGACY
index 59bc18b6727a832129c48aa1b06a39e91f50d792..5705ce0e0c0a470567a398f4cd7eb8eeebe98bf5 100644 (file)
@@ -28,36 +28,18 @@ config BR2_PACKAGE_FREERDP
 
 if BR2_PACKAGE_FREERDP
 
-choice
-       bool "gstreamer support"
-       depends on BR2_PACKAGE_XORG7 # xlib-libxrandr
-       depends on BR2_PACKAGE_GSTREAMER || BR2_PACKAGE_GSTREAMER1
-
 config BR2_PACKAGE_FREERDP_GSTREAMER1
-       bool "gstreamer-1.x"
+       bool "gstreamer support"
        depends on BR2_PACKAGE_GSTREAMER1
+       depends on BR2_PACKAGE_XORG7 # xlib-libxrandr
        # gstreamer-1.x dependencies already dependencies of FreeRDP
        select BR2_PACKAGE_GST1_PLUGINS_BASE
        select BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_APP
        select BR2_PACKAGE_XLIB_LIBXRANDR
 
-config BR2_PACKAGE_FREERDP_GSTREAMER
-       bool "gstreamer-0.x"
-       depends on BR2_PACKAGE_GSTREAMER
-       # gstreamer-0.x dependencies already dependencies of FreeRDP
-       select BR2_PACKAGE_GST_PLUGINS_BASE
-       select BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_APP
-       select BR2_PACKAGE_XLIB_LIBXRANDR
-       select BR2_PACKAGE_LIBXML2
-
-config BR2_PACKAGE_FREERDP_GSTREAMER_NO
-       bool "none"
-
-endchoice
-
 comment "gstreamer support needs X.Org"
        depends on !BR2_PACKAGE_XORG7
-       depends on BR2_PACKAGE_GSTREAMER || BR2_PACKAGE_GSTREAMER1
+       depends on BR2_PACKAGE_GSTREAMER1
 
 config BR2_PACKAGE_FREERDP_SERVER
        bool "server"
index 293b6b5c01f5e81b02a1cad8ec12c4366d225f16..a477e74cb7d051045562150199a7ad09980fd62c 100644 (file)
@@ -12,14 +12,7 @@ FREERDP_LICENSE_FILES = LICENSE
 
 FREERDP_INSTALL_STAGING = YES
 
-FREERDP_CONF_OPTS = -DWITH_MANPAGES=OFF -Wno-dev
-
-ifeq ($(BR2_PACKAGE_FREERDP_GSTREAMER),y)
-FREERDP_CONF_OPTS += -DWITH_GSTREAMER_0_10=ON
-FREERDP_DEPENDENCIES += gstreamer gst-plugins-base libxml2
-else
-FREERDP_CONF_OPTS += -DWITH_GSTREAMER_0_10=OFF
-endif
+FREERDP_CONF_OPTS = -DWITH_MANPAGES=OFF -Wno-dev -DWITH_GSTREAMER_0_10=OFF
 
 ifeq ($(BR2_PACKAGE_FREERDP_GSTREAMER1),y)
 FREERDP_CONF_OPTS += -DWITH_GSTREAMER_1_0=ON