package/boinc: set curl-config
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 10 Apr 2020 21:00:25 +0000 (23:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Apr 2020 07:48:58 +0000 (09:48 +0200)
Build can fail because boinc uses curl-config that it founds on host:

checking for curl-config... /usr/bin/curl-config
checking for the version of libcurl... 7.47.0
checking for libcurl >= version 7.17.1... yes
checking whether libcurl is usable... no

Fixes:
 - http://autobuild.buildroot.org/results/26ab8024e3ef70b898981763f4ea89b647cc9f4b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/boinc/boinc.mk

index d32b258ea7d6fa2217f5c2707fa2626534752ab7..a47ad9abe6bccf8751083c992b7dd68bd4855690 100644 (file)
@@ -12,6 +12,7 @@ BOINC_LICENSE = LGPL-3.0+
 BOINC_LICENSE_FILES = COPYING COPYING.LESSER
 BOINC_DEPENDENCIES = host-pkgconf libcurl openssl
 BOINC_AUTORECONF = YES
+BOINC_CONF_ENV = ac_cv_path__libcurl_config=$(STAGING_DIR)/usr/bin/curl-config
 BOINC_CONF_OPTS = \
        --disable-apps \
        --disable-boinczip \