postgresql: enable ldap support for pg_service.conf
authorChris Frederick <cdf123@cdf123.net>
Mon, 24 Oct 2016 14:13:18 +0000 (09:13 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 24 Oct 2016 15:44:54 +0000 (17:44 +0200)
Just needed to add --with-ldap to POSTGRESQL_CONF_OPTS and add openldap
to POSTGRESQL_DEPENDENCIES when BR2_PACKAGE_OPENLDAP is on

Signed-off-by: Chris Frederick <cdf123@cdf123.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/postgresql/postgresql.mk

index e2756bf10de6e6196c1c52dc084e3225573b4222..1b184e71e1a71d1301a547d824f2b0fbdb3a3b0f 100644 (file)
@@ -57,6 +57,13 @@ POSTGRESQL_DEPENDENCIES += openssl
 POSTGRESQL_CONF_OPTS += --with-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_OPENLDAP),y)
+POSTGRESQL_DEPENDENCIES += openldap
+POSTGRESQL_CONF_OPTS += --with-ldap
+else
+POSTGRESQL_CONF_OPTS += --without-ldap
+endif
+
 define POSTGRESQL_USERS
        postgres -1 postgres -1 * /var/lib/pgsql /bin/sh - PostgreSQL Server
 endef