package/libuio: add missing dependency on host-pkgconf
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 10 Dec 2019 22:10:22 +0000 (23:10 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Dec 2019 07:28:20 +0000 (08:28 +0100)
configure fails if the pkgconfig.m4 macros are not available during
this package autoreconf:

./configure: line 12003: syntax error near unexpected token `PKGCONF,'
./configure: line 12003: `   PKG_CHECK_MODULES(PKGCONF, glib-2.0)

Fixes:

  http://autobuild.buildroot.net/results/9be944e35090bf270fbc9572423466be9af7b1f2/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libuio/libuio.mk

index 13429ec0f1a6dff5d82700e432d9ff7552b723f4..b6e8e7e77485fc9f3f710d69a0f50572cc1e7a54 100644 (file)
@@ -10,7 +10,7 @@ LIBUIO_SITE = $(call github,Linutronix,libuio,$(LIBUIO_VERSION))
 LIBUIO_LICENSE = LGPL-2.1 (library), GPL-2.0 (programs)
 LIBUIO_LICENSE_FILES = COPYING
 LIBUIO_CONF_OPTS = --with-glib=no --without-werror
-LIBUIO_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
+LIBUIO_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) host-pkgconf
 LIBUIO_LIBS = $(TARGET_NLS_LIBS)
 LIBUIO_INSTALL_STAGING = YES