pciutils: SHARED make opt goes for install too
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Jan 2011 13:47:23 +0000 (10:47 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Jan 2011 13:52:02 +0000 (14:52 +0100)
If we don't pass SHARED when installing we miss the shared library
symlinks (libpci.so & libpci.so.3).

On internal and external toolchains that have a proper cross ldconfig this
isn't a problem as they get created during ldconfig, but it breaks on
toolchains that lack a cross ldconfig to automagically make the symlinks.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pciutils/pciutils.mk

index 6e163006bceb3084a1e513d4c90c5c562b3450a6..782d348ea8b18b4ccbed1f5620f86141cf0e3b92 100644 (file)
@@ -39,8 +39,10 @@ endef
 
 # Ditch install-lib if SHARED is an option in the future
 define PCIUTILS_INSTALL_TARGET_CMDS
-       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install
-       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib
+       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+               SHARED=$(PCIUTILS_SHARED) install
+       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+               SHARED=$(PCIUTILS_SHARED) install-lib
 endef
 
 $(eval $(call GENTARGETS,package,pciutils))