core: move generated .br2-external kconfig file to $(BASE_DIR)
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 29 Jul 2019 20:19:53 +0000 (22:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Aug 2019 19:51:40 +0000 (21:51 +0200)
Currently, that file is generated rather late in the configuration
process, so BUILD_DIR is known (and exists) by then.

We're soon to generate that file much earlier, at a point where
BUILD_DIR is not yet known, so we have two options:
 1- declare BUILD_DIR earlier;
 2- generate the file in an already-known location.

We go with the second solution, as we're already generating a
br2-external related file in BASE_DIR, so we can as well generate all
br2-external files in the same place.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
Makefile

index 757ad1ca405e4c58bff8744a49a4bb5e02ef6a7e..c611bb7decdcebeccca008928735a31eb00471d9 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -14,9 +14,9 @@ config BR2_HOSTARCH
        string
        option env="HOSTARCH"
 
-config BR2_BUILD_DIR
+config BR2_BASE_DIR
        string
-       option env="BUILD_DIR"
+       option env="BASE_DIR"
 
 # Hidden config symbols for packages to check system gcc version
 config BR2_HOST_GCC_VERSION
@@ -865,4 +865,4 @@ source "package/Config.in.host"
 
 source "Config.in.legacy"
 
-source "$BR2_BUILD_DIR/.br2-external.in"
+source "$BR2_BASE_DIR/.br2-external.in"
index 9cce9349904d5b7331f0590d53de3953afd2de23..a7af04fb4bfc5a5a0d802faf229249c9bea28ca3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -934,7 +934,7 @@ HOSTCFLAGS = $(CFLAGS_FOR_BUILD)
 export HOSTCFLAGS
 
 .PHONY: prepare-kconfig
-prepare-kconfig: outputmakefile $(BUILD_DIR)/.br2-external.in
+prepare-kconfig: outputmakefile $(BASE_DIR)/.br2-external.in
 
 $(BUILD_DIR)/buildroot-config/%onf:
        mkdir -p $(@D)/lxdialog
@@ -952,7 +952,7 @@ COMMON_CONFIG_ENV = \
        KCONFIG_TRISTATE=$(BUILD_DIR)/buildroot-config/tristate.config \
        BR2_CONFIG=$(BR2_CONFIG) \
        HOST_GCC_VERSION="$(HOSTCC_VERSION)" \
-       BUILD_DIR=$(BUILD_DIR) \
+       BASE_DIR=$(BASE_DIR) \
        SKIP_LEGACY=
 
 xconfig: $(BUILD_DIR)/buildroot-config/qconf prepare-kconfig
@@ -1034,8 +1034,8 @@ endif
 # Even though the target is a real file, we mark it as PHONY as we
 # want it to be re-generated each time make is invoked, in case the
 # value of BR2_EXTERNAL is changed.
-.PHONY: $(BUILD_DIR)/.br2-external.in
-$(BUILD_DIR)/.br2-external.in: $(BUILD_DIR)
+.PHONY: $(BASE_DIR)/.br2-external.in
+$(BASE_DIR)/.br2-external.in: $(BUILD_DIR)
        $(Q)support/scripts/br2-external -k -o "$(@)" $(BR2_EXTERNAL)
 
 # printvars prints all the variables currently defined in our
@@ -1066,7 +1066,7 @@ ifeq ($(O),$(CURDIR)/output)
        rm -rf $(O)
 endif
        rm -rf $(TOPDIR)/dl $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
-               $(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE)
+               $(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE) $(BASE_DIR)/.br2-external.in
 
 .PHONY: help
 help: