uboot-tools: fix install commands
authorHenri Bragge <henri.bragge@gmail.com>
Fri, 16 Dec 2011 20:08:59 +0000 (22:08 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 17 Dec 2011 21:31:51 +0000 (22:31 +0100)
Signed-off-by: Henri Bragge <henri.bragge@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/uboot-tools/uboot-tools.mk

index e20560ab234685b293dbed1c86db066570a9fd2e..00592d6eb289ac746be67ceedaaad53ee71f0412 100644 (file)
@@ -13,13 +13,13 @@ endef
 
 ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_MKIMAGE),y)
 define UBOOT_TOOLS_INSTALL_MKIMAGE
-       install -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin
+       $(INSTALL) -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin/mkimage
 endef
 endif
 
 ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_FWPRINTENV),y)
 define UBOOT_TOOLS_INSTALL_FWPRINTENV
-       install -m 0755 -D $(@D)/tools/env/fw_printenv $(TARGET_DIR)/usr/sbin
+       $(INSTALL) -m 0755 -D $(@D)/tools/env/fw_printenv $(TARGET_DIR)/usr/sbin/fw_printenv
        ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
 endef
 endif
@@ -48,7 +48,7 @@ define HOST_UBOOT_TOOLS_BUILD_CMDS
 endef
 
 define HOST_UBOOT_TOOLS_INSTALL_CMDS
-       install -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin
+       $(INSTALL) -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin/mkimage
 endef
 
 $(eval $(call GENTARGETS))