Mention how people can update things
authorEric Andersen <andersen@codepoet.org>
Sat, 18 Jan 2003 21:52:46 +0000 (21:52 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 18 Jan 2003 21:52:46 +0000 (21:52 -0000)
Makefile
make/customize.mk [new file with mode: 0644]

index cde7e4cc2fcdc6366532abe6a316609e9250160a..60c386b3d3911c24fba30856a81fd464131eef79 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -103,7 +103,16 @@ TARGETS+=busybox tinylogin
 # The Valgrind debugger (x86 only)
 #TARGETS+=valgrind
 
+# Run customize.mk at the very end to add your own special config.
+# This is useful for making your own distro within the buildroot
+# process.
+# TARGETS+=customize
+
+#############################################################
+#
 # Pick your root filesystem type.
+#
+#############################################################
 TARGETS+=ext2root
 
 # Must mount cramfs with 'ramdisk_blocksize=4096'
diff --git a/make/customize.mk b/make/customize.mk
new file mode 100644 (file)
index 0000000..2cfed18
--- /dev/null
@@ -0,0 +1,10 @@
+#############################################################
+#
+# Any custom stuff you feel like doing....
+#
+#############################################################
+CUST_DIR:=$(SOURCE_DIR)/customize
+ROOT_DIR:=$(BUILD_DIR)/root
+
+customize:
+       cp -af $(CUST_DIR)/* $(ROOT_DIR)/