Replace configuring GLIB with autodetect
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 6 Jul 2008 07:34:41 +0000 (07:34 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 6 Jul 2008 07:34:41 +0000 (07:34 -0000)
Config.in
Makefile

index 129171bbf995a809c49ddb3c29f510cc134974ca..60aefc92c6c54af07a7440db2faec0ed15c81f78 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -78,17 +78,6 @@ config BR2_DL_DIR
 
          The default is $(BASE_DIR)/dl
 
-config BR2_HOST_GLIB
-       string "Location of host Gnome library"
-       default "/usr"
-       help
-         Directory where Gnome is installed on the host
-         Gnome applications is installed in $(BR2_HOST_LIB)/bin 
-         This is needed to build libgtk etc.
-         The default is /usr
-         It can be overridden by the BUILDROOT_HOST_GLIB
-         shell variable
-
 source "target/device/Config.in.mirrors"
 
 config BR2_STAGING_DIR
index 8255771cacf35fe14896bf79448582dab6f8a9c1..ff8108b0e4929e354e757e66d89f4c31641fd68c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -57,12 +57,6 @@ BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
 endif
 LOCAL:=$(BR2_LOCAL)
 
-ifneq ($(BUILDROOT_HOST_GLIB),)
-HOST_GLIB:=$(BUILDROOT_HOST_GLIB)
-else
-HOST_GLIB:=$(BR2_HOST_GLIB)
-endif
-
 # To put more focus on warnings, be less verbose as default
 # Use 'make V=1' to see the full commands
 ifdef V
@@ -128,6 +122,10 @@ HOSTCPP:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCPP)" || type -p $(HOSTCPP) ||
 HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
 HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
 HOSTNM:=$(shell $(CONFIG_SHELL) -c "which $(HOSTNM)" || type -p $(HOSTNM) || echo nm)
+HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "which glib-genmarshal" || echo /usr/bin/glib-genmarshal)`
+HOST_GLIB:=$(shell $(CONFIG_SHELL) -c "dirname $(HOST_GLIB_BIN)" || echo /usr)
+
+
 ifndef CFLAGS_FOR_BUILD
 CFLAGS_FOR_BUILD:=-g -O2
 endif
@@ -522,3 +520,4 @@ status:
        @echo LOCAL=$(LOCAL)
        @echo BR2_DL_DIR=$(BR2_DL_DIR)
        @echo HOST_GLIB=$(HOST_GLIB)
+       @echo HOST_GLIB_BIN=$(HOST_GLIB_BIN)