package/syslog-ng: implement systemd enablement using DefaultInstance
authorJérémy Rosen <jeremy.rosen@smile.fr>
Mon, 16 Dec 2019 10:30:50 +0000 (11:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 17:33:22 +0000 (18:33 +0100)
Instead of using a manual symlink we use add a DefaultInstance= to the
config file

This is how upstream wants us to do it and allows systemctl preset to
correctly restore it if needed

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
[yann.morin.1998@free.fr:
  - split long line
  - no need for continued line (no use for ';\' )
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/syslog-ng/syslog-ng.mk

index fc44777d161526eb9896ed11ac33172f12619344..68260172a2d6f62b4ce44af662ca11eda1c73ff1 100644 (file)
@@ -105,11 +105,9 @@ endef
 # By default syslog-ng installs a .service that requires a config file at
 # /etc/default, so provide one with the default values.
 define SYSLOG_NG_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -m 0644 -D package/syslog-ng/syslog-ng@default \
-               $(TARGET_DIR)/etc/default/syslog-ng@default
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -sf ../../../../usr/lib/systemd/system/syslog-ng@.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/syslog-ng@default.service
+       mkdir $(TARGET_DIR)/usr/lib/systemd/system/syslog-ng@.service.d
+       printf '[Install]\nDefaultInstance=default\n' \
+               >$(TARGET_DIR)/usr/lib/systemd/system/syslog-ng@.service.d/buildroot-default-instance.conf
 endef
 
 # By default syslog-ng installs a number of sample configuration