yasm: minor fixes that should have been part the commit adding the package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Aug 2012 20:33:40 +0000 (22:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Aug 2012 20:33:40 +0000 (22:33 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/yasm/Config.in
package/yasm/yasm.mk

index bb1d41722918d3a3b0b4a4217c34eec34e88ceeb..2dc25aadb21c895c7c60023337c7900dd0e77760 100644 (file)
@@ -7,3 +7,4 @@ config BR2_PACKAGE_YASM
          and GAS assembler syntaxes and outputs binary, ELF32 and ELF64
          object formats.
 
+         http://www.tortall.net/projects/yasm/
index ac75d2b6abdd9ae51f24124b6f1a7e559a07d53b..fafd1ec6dc6a6f140f4f7fe3a80105525e4561c8 100644 (file)
@@ -6,7 +6,6 @@
 YASM_VERSION = 1.2.0
 YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
 YASM_SITE = http://www.tortall.net/projects/yasm/releases/
-YASM_CONF_OPT = --disable-static
 
 define YASM_PRE_CONFIGURE_FIXUP
 # This sed prevents it compiling 2 programs (vsyasm and ytasm) 
@@ -15,6 +14,7 @@ define YASM_PRE_CONFIGURE_FIXUP
 endef
 
 YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+HOST_YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))