cppzmq: new package
authorSimon Dawson <spdawson@gmail.com>
Mon, 25 Mar 2013 13:28:02 +0000 (13:28 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Mar 2013 08:49:41 +0000 (09:49 +0100)
Now that zeromq has been bumped to version 3.2.2, we need to provide the
C++ binding using a separate package. The cppzmq package provides a simple
single-header C++ binding.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
[yann.morin.1998@free.fr: add comment about no license file]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/cppzmq/Config.in [new file with mode: 0644]
package/cppzmq/cppzmq.mk [new file with mode: 0644]

index d3901b40d2018d8a51f1f35d3875f5c019a2821d..23c9bb3496bf34dc5e8c59d49d75f5b4d0aec18c 100644 (file)
@@ -497,6 +497,7 @@ endmenu
 
 menu "Networking"
 source "package/czmq/Config.in"
+source "package/cppzmq/Config.in"
 source "package/glib-networking/Config.in"
 source "package/libcgi/Config.in"
 source "package/libcgicc/Config.in"
diff --git a/package/cppzmq/Config.in b/package/cppzmq/Config.in
new file mode 100644 (file)
index 0000000..ea632d1
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_CPPZMQ
+       bool "cppzmq"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_INET_IPV6 # zeromq
+       depends on BR2_LARGEFILE # util-linux
+       depends on BR2_USE_WCHAR # util-linux
+       select BR2_PACKAGE_ZEROMQ
+       help
+         C++ binding for zeromq (ZeroMQ, 0MQ, zmq).
+
+         http://github.com/zeromq/cppzmq
+
+comment "cppzmq requires a toolchain with C++, IPV6, LARGEFILE and WCHAR support"
+       depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_LARGEFILE \
+               && BR2_USE_WCHAR)
diff --git a/package/cppzmq/cppzmq.mk b/package/cppzmq/cppzmq.mk
new file mode 100644 (file)
index 0000000..d4609bf
--- /dev/null
@@ -0,0 +1,23 @@
+#############################################################
+#
+# cppzmq
+#
+#############################################################
+
+CPPZMQ_VERSION = b232978
+CPPZMQ_SITE = git://github.com/zeromq/cppzmq.git
+CPPZMQ_INSTALL_STAGING = YES
+CPPZMQ_DEPENDENCIES = zeromq
+CPPZMQ_LICENSE = MIT
+# No license file, the license is in the installed header
+CPPZMQ_LICENSE_FILES = zmq.hpp
+
+define CPPZMQ_INSTALL_STAGING_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/zmq.hpp $(STAGING_DIR)/usr/include/zmq.hpp
+endef
+
+define CPPZMQ_UNINSTALL_STAGING_CMDS
+       $(RM) $(STAGING_DIR)/usr/include/zmq.hpp
+endef
+
+$(eval $(generic-package))