package/gnuradio: add optional support for orc
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:34:50 +0000 (18:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2016 21:20:25 +0000 (22:20 +0100)
When orc was compiled before, gnuradio will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/gnuradio-config-info | grep NEEDED
[...]
 0x0000000000000001 (NEEDED)             Shared library: [liborc-0.4.so.0]
[...]

Apparently there is no option provided by the build system to
en-/disable support for orc:
https://github.com/gnuradio/volk/blob/41b4df055b2c8d4f2c23ad2bdc60c0b47b4f0dd8/lib/CMakeLists.txt#L449

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Gwenhael Goavec-Merou" <gwenhael.goavec-merou@trabucayre.com>
Tested-by: "Gwenhael Goavec-Merou" <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnuradio/gnuradio.mk

index fc5cd1fa596177c3a93bb15403a3a3573bee481e..b7dbcb9fdd518e3847ba019104d671a46a3fbc4a 100644 (file)
@@ -17,6 +17,10 @@ GNURADIO_DEPENDENCIES = \
        host-swig \
        boost
 
+ifeq ($(BR2_PACKAGE_ORC),y)
+GNURADIO_DEPENDENCIES += orc
+endif
+
 GNURADIO_CONF_OPTS = \
        -DENABLE_DEFAULT=OFF \
        -DENABLE_VOLK=ON \