dhcpcd: needs MMU
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Nov 2013 13:47:01 +0000 (14:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Nov 2013 21:00:19 +0000 (22:00 +0100)
dhcpcd fails to build on non-MMU platforms, even with the
--disable-fork option:

  bind.o: In function `_daemonise':
  bind.c:(.text+0x62): undefined reference to `_fork'
  collect2: ld returned 1 exit status

Therefore, we make dhcpcd depend on MMU support, and remove the
non-MMU condition in the .mk file. More recent versions of dhcpcd do
support non-MMU properly, but this commit intends to be only a fix.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: Samuel Martin <s.martin49@gmail.com>
package/dhcpcd/Config.in
package/dhcpcd/dhcpcd.mk

index dbde548db021138af5de6a087544285c5fe3f17e..ddbc6f47812c1bc85096191c06665809043037a4 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_DHCPCD
        depends on BR2_INET_IPV6
+       depends on BR2_USE_MMU # fork()
        bool "dhcpcd"
        help
          An RFC2131 compliant DHCP client
index 5296db8744394380d5863d126686ec0b3612d5cb..13810f3a4620fa814cd5eecbd0fdae170143d6a4 100644 (file)
@@ -9,10 +9,6 @@ DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
 DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd/
 DHCPCD_LICENSE = BSD-2c
 
-ifeq ($(BR2_USE_MMU),)
-       DHCPCD_CONFIG_OPT += --disable-fork
-endif
-
 define DHCPCD_CONFIGURE_CMDS
        (cd $(@D); \
        ./configure \