projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c9306ec
)
Automate the usage of '--disable-gdbmi' to be used only with GDB versions less than...
author
"Steven J. Hill"
<sjhill@realitydiluted.com>
Wed, 5 Jul 2006 05:12:51 +0000
(
05:12
-0000)
committer
"Steven J. Hill"
<sjhill@realitydiluted.com>
Wed, 5 Jul 2006 05:12:51 +0000
(
05:12
-0000)
toolchain/gdb/gdb.mk
patch
|
blob
|
history
diff --git
a/toolchain/gdb/gdb.mk
b/toolchain/gdb/gdb.mk
index be3a388f09e38a6c1b942230628fa1f5ae6e3ad7..6b8a0df6f84e172107661565427fa2f98f57e7bc 100644
(file)
--- a/
toolchain/gdb/gdb.mk
+++ b/
toolchain/gdb/gdb.mk
@@
-19,10
+19,16
@@
GDB_CAT:=bzcat
GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(GDB_VERSION)
-# NOTE: This option should not be used with newer gdb versions.
+# NOTE: This option should not be used with gdb versions 6.4 and above.
+ifeq ($(GDB_VERSION),6.2.1)
DISABLE_GDBMI:=--disable-gdbmi
endif
+ifeq ($(GDB_VERSION),6.3)
+DISABLE_GDBMI:=--disable-gdbmi
+endif
+endif
+
$(DL_DIR)/$(GDB_SOURCE):
$(WGET) -P $(DL_DIR) $(GDB_SITE)/$(GDB_SOURCE)