busybox: force lfs build
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 30 Mar 2015 21:07:27 +0000 (18:07 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Apr 2015 20:43:32 +0000 (22:43 +0200)
Drop the buildroot toolchain non-largefile support option since it's
being removed.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk

index 7412ce0bec492b3664affe23448cccfe2d155b9c..95fdfec4e8e6a1a8a23f89257597db3187529744 100644 (file)
@@ -92,17 +92,10 @@ define BUSYBOX_SET_MMU
 endef
 endif
 
-ifeq ($(BR2_LARGEFILE),y)
 define BUSYBOX_SET_LARGEFILE
        $(call KCONFIG_ENABLE_OPT,CONFIG_LFS,$(BUSYBOX_BUILD_CONFIG))
        $(call KCONFIG_ENABLE_OPT,CONFIG_FDISK_SUPPORT_LARGE_DISKS,$(BUSYBOX_BUILD_CONFIG))
 endef
-else
-define BUSYBOX_SET_LARGEFILE
-       $(call KCONFIG_DISABLE_OPT,CONFIG_LFS,$(BUSYBOX_BUILD_CONFIG))
-       $(call KCONFIG_DISABLE_OPT,CONFIG_FDISK_SUPPORT_LARGE_DISKS,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
 
 # If IPv6 is enabled then enable basic ifupdown support for it
 ifeq ($(BR2_INET_IPV6),y)