package/x11r7/xserver_xorg-server: remove evdev input drivers for kdrive
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 15 Apr 2021 06:52:44 +0000 (08:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 15 Apr 2021 21:34:34 +0000 (23:34 +0200)
Upstream removed the evdev driver for kdrive:
https://cgit.freedesktop.org/xorg/xserver/commit/configure.ac?h=server-1.20-branch&id=27819950e4158326e0f83a30f2e8968b932625ef

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index d22dca9a53af7403a9b76e6c24b76ea32851a276..c2b0645eaf05ef7c6b3e762ba914b6f8af9eee52 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2021.05"
 
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV
+       bool "KDrive/TinyX evdev input driver removed"
+       select BR2_LEGACY
+       help
+         The evdev input driver in KDrive was removed.
+
 config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD
        bool "KDrive/TinyX kbd input driver removed"
        select BR2_LEGACY
index 1b9adadb5c2d02d092ded9760b29c6ea1b5242aa..fcd3d0ae004c4000a00463b913524fdf490e96d5 100644 (file)
@@ -74,24 +74,6 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
 
 endchoice
 
-if BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
-
-config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV
-       bool "Enable KDrive/TinyX evdev input driver"
-       help
-         Enable evdev input driver in KDrive. This allows KDrive to
-         use input devices that are integrated in the Linux input
-         subsystem, i.e have a /dev/input/eventX device file. This is
-         most likely the input driver you want to use.
-
-         This driver can then be enabled by running the X server
-         using:
-
-         Xfbdev -keybd evdev,,device=/dev/input/eventX
-                -mouse evdev,,device=/dev/input/eventY
-
-endif
-
 comment "Optional Servers"
 
 config BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB
index aaf35847721823e7b4e707d020cc24a71ddaa95e..8bd92b7ab69bf4b44c49cf3e500f1baf8158ed32 100644 (file)
@@ -94,12 +94,6 @@ XSERVER_XORG_SERVER_CONF_OPTS += \
        --disable-dri \
        --disable-xsdl
 
-ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV),y)
-XSERVER_XORG_SERVER_CONF_OPTS += --enable-kdrive-evdev
-else
-XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive-evdev
-endif
-
 else # modular
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive
 endif