package/mutt: add zlib optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 23 Dec 2020 10:59:49 +0000 (11:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:22:26 +0000 (18:22 +0100)
zlib is an optional dependency which is enabled by default since version
1.14.1 and
https://gitlab.com/muttmua/mutt/-/commit/136ae0add512f21bc418f9e31a2f1b970ad1a490

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mutt/mutt.mk

index cc4b5f56b434ffa958532064d27df36a7e05e102..4e140045775fb91f03a03748bdbe2dfdc3b1bda2 100644 (file)
@@ -61,6 +61,13 @@ else
 MUTT_CONF_OPTS += --without-sqlite3
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+MUTT_DEPENDENCIES += zlib
+MUTT_CONF_OPTS += --with-zlib=$(STAGING_DIR)/usr
+else
+MUTT_CONF_OPTS += --without-zlib
+endif
+
 # Avoid running tests to check for:
 #  - target system is *BSD
 #  - C99 conformance (snprintf, vsnprintf)