package/gcc: disable libsanitizer for uClibc
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 24 Apr 2014 01:00:32 +0000 (22:00 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 24 Apr 2014 11:46:43 +0000 (13:46 +0200)
libsanitizer requires wordexp() support which we lack in our current
default uClibc configurations (and it's fat & big).
Hence disable it when the toolchain is uClibc-based.
It only affects gcc 4.9+ since it's default on now for supported
platforms.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index dff6dce46642882d0e0b9e8bb35ab484683e81d6..32219cc3db2300bd8f1118a0bbf406cf6aafb56a 100644 (file)
@@ -125,6 +125,11 @@ ifneq ($(BR2_TOOLCHAIN_BUILDROOT_WCHAR),y)
 HOST_GCC_COMMON_CONF_OPT += --disable-libquadmath
 endif
 
+# libsanitizer requires wordexp, not in default uClibc config
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC),y)
+HOST_GCC_COMMON_CONF_OPT += --disable-libsanitizer
+endif
+
 ifeq ($(BR2_GCC_ENABLE_TLS),y)
 HOST_GCC_COMMON_CONF_OPT += --enable-tls
 else