php-ssh2: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 28 Jan 2014 21:26:30 +0000 (18:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 12 Feb 2014 14:57:38 +0000 (15:57 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/php-ssh2/Config.in [new file with mode: 0644]
package/php-ssh2/php-ssh2.mk [new file with mode: 0644]

index 89988829759adc7bf77c3caff43dc6b4f5a5da42..1fd47191d35a464bf717df2ee74716f4923cb187 100644 (file)
@@ -397,6 +397,7 @@ source "package/php/Config.in"
 if BR2_PACKAGE_PHP
 if !BR2_PREFER_STATIC_LIB
 menu "External php extensions"
+source "package/php-ssh2/Config.in"
 source "package/php-yaml/Config.in"
 source "package/php-zmq/Config.in"
 endmenu
diff --git a/package/php-ssh2/Config.in b/package/php-ssh2/Config.in
new file mode 100644 (file)
index 0000000..b457900
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PHP_SSH2
+       bool "php-ssh2"
+       depends on BR2_PACKAGE_PHP
+       select BR2_PACKAGE_LIBSSH2
+       help
+         PHP bindings for the libssh2 library.
+
+         http://pecl.php.net/package/ssh2
diff --git a/package/php-ssh2/php-ssh2.mk b/package/php-ssh2/php-ssh2.mk
new file mode 100644 (file)
index 0000000..f2067a4
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# php-ssh2
+#
+################################################################################
+
+PHP_SSH2_VERSION = 0.12
+PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
+PHP_SSH2_SITE = http://pecl.php.net/get
+PHP_SSH2_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+       --with-ssh2=$(STAGING_DIR)/usr
+# phpize does the autoconf magic
+PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
+PHP_SSH2_LICENSE = PHP
+PHP_SSH2_LICENSE_FILES = LICENSE
+
+define PHP_SSH2_PHPIZE
+       (cd $(@D); \
+               PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+               PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+               $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
+
+$(eval $(autotools-package))