package/vlc: add optional dependency to harfbuzz
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:27 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:25 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 6643d6fd8d1ad7b498b3d9e6c0f6ede59a158183..7ce1f57cd896ec512f7bd695e43a1628fa5e6a43 100644 (file)
@@ -59,7 +59,6 @@ VLC_CONF_OPTS += \
        --disable-fluidsynth \
        --disable-gme \
        --disable-goom \
-       --disable-harfbuzz \
        --disable-jack \
        --disable-jpeg \
        --disable-kai \
@@ -191,6 +190,13 @@ ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
 VLC_DEPENDENCIES += libgl
 endif
 
+ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
+VLC_CONF_OPTS += --enable-harfbuzz
+VLC_DEPENDENCIES += harfbuzz
+else
+VLC_CONF_OPTS += --disable-harfbuzz
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
 VLC_CONF_OPTS += --enable-gles2
 VLC_DEPENDENCIES += libgles