package/mplayer: add optional libiconv support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:30 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 21:01:25 +0000 (23:01 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 5e295515f40c12aa9fd2f8b6ef7f4b95676a42bc..2ddc0fc370d302a14bed945813ff44abee381cda 100644 (file)
@@ -68,6 +68,14 @@ else
 MPLAYER_CONF_OPTS += --disable-fribidi
 endif
 
+# We intentionally don't pass --enable-libiconv, to let the
+# autodetection find which library to link with.
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MPLAYER_DEPENDENCIES += libiconv
+else
+MPLAYER_CONF_OPTS += --disable-iconv
+endif
+
 # We intentionally don't pass --enable-termcap, in order to let the
 # autodetection find with which library to link with. Otherwise, we
 # would have to pass it manually.