reaver: new package
authorGuillaume W. Bres <guillaume.bressaix@gmail.com>
Thu, 12 Apr 2018 11:44:33 +0000 (13:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 12 Apr 2018 19:31:06 +0000 (21:31 +0200)
Reaver is a tool to audit networks against brute WPS pins attacks.

We use the github.com/t6x fork at the moment because other
versions/repos of this project won't cross-compile, and this fork is
the only one regularly updated and maintained.

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/reaver/Config.in [new file with mode: 0644]
package/reaver/reaver.hash [new file with mode: 0644]
package/reaver/reaver.mk [new file with mode: 0644]

index 00cbaeff378890c5d004988efab6fef4a93057c6..f52cb884dba3728462a5c04cac2ce7d5859ccfe7 100644 (file)
@@ -794,6 +794,7 @@ F:  package/sdl2/
 
 N:     Guillaume William Brs <guillaume.bressaix@gmail.com>
 F:     package/liquid-dsp/
+F:     package/reaver/
 
 N:     Guo Ren <ren_guo@c-sky.com>
 F:     arch/Config.in.csky
index e48d0b4c644c7ac2324453606636335ece0aa254..2da86057fdd7aafb439c046c624519ec96fce785 100644 (file)
@@ -1823,6 +1823,7 @@ endif
        source "package/quagga/Config.in"
        source "package/rabbitmq-server/Config.in"
        source "package/radvd/Config.in"
+       source "package/reaver/Config.in"
        source "package/rp-pppoe/Config.in"
        source "package/rpcbind/Config.in"
        source "package/rsh-redone/Config.in"
diff --git a/package/reaver/Config.in b/package/reaver/Config.in
new file mode 100644 (file)
index 0000000..0fd8ab7
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_REAVER
+       bool "reaver"
+       select BR2_PACKAGE_LIBPCAP
+       help
+         Reaver is a tool to audit networks against brute WPS pins
+         attacks. It is complementary to "Aircrack-ng".
+
+         https://code.google.com/archive/p/reaver-wps/wikis/README.wiki
+         https://github.com/t6x/reaver-wps-fork-t6x
diff --git a/package/reaver/reaver.hash b/package/reaver/reaver.hash
new file mode 100644 (file)
index 0000000..6d2bacc
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256 350a89b068f8b461e6459b739d4f5f301db01f115d75f4d698a1f2830149c412 reaver-9bae55bd30b6d46b42da3a09dc23c8b0f9341996.tar.gz
+sha256 bb40cfd5e9ca6e8465ea3c236f3f2293e8300af1bfe87e72fabe482ae6cc995a docs/LICENSE
diff --git a/package/reaver/reaver.mk b/package/reaver/reaver.mk
new file mode 100644 (file)
index 0000000..90d1727
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# reaver
+#
+################################################################################
+
+# Older repos for this project will not cross-compile easily
+# while this one works right away
+REAVER_VERSION = 9bae55bd30b6d46b42da3a09dc23c8b0f9341996
+REAVER_SITE = $(call github,t6x,reaver-wps-fork-t6x,$(REAVER_VERSION))
+REAVER_LICENSE = GPL-2.0+
+REAVER_LICENSE_FILES = docs/LICENSE
+
+REAVER_SUBDIR = src
+REAVER_DEPENDENCIES = libpcap
+
+$(eval $(autotools-package))