package/python-terminaltables: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 3 Mar 2019 23:44:18 +0000 (07:44 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Mar 2019 15:23:22 +0000 (16:23 +0100)
Generate simple tables in terminals from a nested list of strings.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-terminaltables/Config.in [new file with mode: 0644]
package/python-terminaltables/python-terminaltables.hash [new file with mode: 0644]
package/python-terminaltables/python-terminaltables.mk [new file with mode: 0644]

index 2da50e0299ba0d1d3a04954115123061d5ebfc74..359f04490ce4be4a73f894d4274f077fe015cdd2 100644 (file)
@@ -1047,6 +1047,7 @@ F:        package/python-async-timeout/
 F:     package/python-cchardet/
 F:     package/python-multidict/
 F:     package/python-pycares/
+F:     package/python-terminaltables/
 F:     package/python-yarl/
 
 N:     James Knight <james.knight@rockwellcollins.com>
index 6891004660d4de6f809544136f779ee56f32cb2c..457018b18e6fdaeb5c19db8468f7d37ae67141e0 100644 (file)
@@ -1051,6 +1051,7 @@ menu "External python modules"
        source "package/python-systemd/Config.in"
        source "package/python-tabledata/Config.in"
        source "package/python-tempora/Config.in"
+       source "package/python-terminaltables/Config.in"
        source "package/python-texttable/Config.in"
        source "package/python-thrift/Config.in"
        source "package/python-tomako/Config.in"
diff --git a/package/python-terminaltables/Config.in b/package/python-terminaltables/Config.in
new file mode 100644 (file)
index 0000000..bb3c51c
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_TERMINALTABLES
+       bool "python-terminaltables"
+       help
+         Generate simple tables in terminals from a nested list of strings.
+
+         https://github.com/Robpol86/terminaltables
diff --git a/package/python-terminaltables/python-terminaltables.hash b/package/python-terminaltables/python-terminaltables.hash
new file mode 100644 (file)
index 0000000..3184f5f
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/terminaltables/json
+md5    863797674d8f75d22e16e6c1fdcbeb41  terminaltables-3.1.0.tar.gz
+sha256 f3eb0eb92e3833972ac36796293ca0906e998dc3be91fbe1f8615b331b853b81  terminaltables-3.1.0.tar.gz
diff --git a/package/python-terminaltables/python-terminaltables.mk b/package/python-terminaltables/python-terminaltables.mk
new file mode 100644 (file)
index 0000000..763f82e
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-terminaltables
+#
+################################################################################
+
+PYTHON_TERMINALTABLES_VERSION = 3.1.0
+PYTHON_TERMINALTABLES_SOURCE = terminaltables-$(PYTHON_TERMINALTABLES_VERSION).tar.gz
+PYTHON_TERMINALTABLES_SITE = https://files.pythonhosted.org/packages/9b/c4/4a21174f32f8a7e1104798c445dacdc1d4df86f2f26722767034e4de4bff
+PYTHON_TERMINALTABLES_SETUP_TYPE = setuptools
+PYTHON_TERMINALTABLES_LICENSE = MIT
+
+$(eval $(python-package))