This fixes make clean on pppd package (there is no rule uninstall in pppd's makefile)
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 28 Aug 2007 18:22:38 +0000 (18:22 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 28 Aug 2007 18:22:38 +0000 (18:22 -0000)
and does some small bits of cleanup.

Signed-off-by: Thiago A. CorrĂȘa <thiago.correa@gmail.com>
package/pppd/pppd.mk

index c72f640c515dae0fa49d6f52d45b6bf82fa30010..c0f584967e6ee0387cf3bc7fc776e03e3adf17c8 100644 (file)
@@ -26,7 +26,7 @@ $(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
        $(SED) 's,(INSTALL) -s,(INSTALL),' $(PPPD_DIR)/pppd/plugins/*/Makefile.linux
        $(SED) 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
        $(SED) 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
-       touch $(PPPD_DIR)/.unpacked
+       touch $@
 
 $(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
        (cd $(PPPD_DIR); rm -rf config.cache; \
@@ -49,7 +49,7 @@ $(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
                --infodir=/usr/info \
                $(DISABLE_NLS) \
        )
-       touch $(PPPD_DIR)/.configured
+       touch $@
 
 $(PPPD_DIR)/$(PPPD_BINARY): $(PPPD_DIR)/.configured
        $(MAKE) CC=$(TARGET_CC) COPTS="$(TARGET_CFLAGS)" -C $(PPPD_DIR)
@@ -65,7 +65,6 @@ pppd-clean:
        rm -f $(TARGET_DIR)/usr/sbin/pppd
        rm -f $(TARGET_DIR)/usr/sbin/chat
        rm -rf $(TARGET_DIR)/etc/ppp
-       $(MAKE) DESTDIR=$(TARGET_DIR)/usr CC=$(TARGET_CC) -C $(PPPD_DIR) uninstall
        -$(MAKE) -C $(PPPD_DIR) clean
 
 pppd-dirclean: